
JS9 Function Manual
JS9 is a JavaScript version of the de facto standard DS9 image display program. It allows you to view
and manipulate astronomical image data in your browser.  The overall function of JS9 is similar to that
of SalsaJ, but can be run on a browser and therefore be used on a Chromebook.

This document contains directions on how to complete the functions of the SalsaJ program utilized in
the Astronomy Modeling Workshop in July 2019 on JS9.
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SalsaJ to JS9 Function Name Translator

SalsaJ Function
(as written in Astronomy

Modeling manual)
→ Comparable JS9 Function

Brightness and Contrast Tool → View → Contrast Sliders
(or just left click/hold and drag)

Image Stacking → Gather/Separate images

Process > Image Calculator >
Addition/Subtraction → View > Basic Image Processing

(though Blending images is preferred)

Image > Stacks > Start Animation → Blinking

Scrolling Tool (Hand) → Right Click/hold and drag
OR use panner tool

Magnifying Glass → Magnifier

Straight Line Selection → Regions > Line OR click the icon on the toolbar

Plot Profile tool → Analysis > Plot Profile

Scale tool →

Does Not Exist.

Find Pixel Conversion Factor (Pixel Value
Length/Known Length) to determine the size of

unknowns

Process > rotate →

R. Curtiss 2019
1



Link for JS9
http://hou-js9plugins.educontinuum.org/

This link is to a version of JS9 that has been modified with the plug-ins below to better mirror the
functionality and design of SalsaJ.

Plot profile Plugin:
● Open an image file, then go to menu "Analysis", and click on "Plot Profile". You can now see plot

profile of any line region you add

Contrast Plugin:
● Open an image file, then go to "View" menu, and click on "Contrast sliders". You can now adjust

contrast by moving the two sliders

Photometry Plugin:
● Open an image file, then go to menu "Analysis", and click on "Photometry". You can use 3

circles annulus regions tu calculate photometry. Pixel inside the smallest circle must be star
pixel. Pixel between the two largest circles will be sky pixel

Basic Image processing:
● Open an image file, then go to "View" menu, and click on "Basic Image processing"
● Draw a box region, then click on "Extract Sub image" to create a new FITS image containing

only the content of the box region
● Open two same size images, select them on the two dropdown lists, and click on add of

subtract. A third image which is the addition / subtraction of the two first will be created
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Opening an Image(s)

Image files must be on a local drive (hard drive or USB flash drive).  They cannot be pulled from an
online source, like a Google Drive.

Click: File > Load Local File ...

Locate the image file(s) to open.  You may need to select ‘All Files *.*’ to find your image files
depending on their extension.

Select more than one file by using the standard ‘Control-click’ or ‘Shift-click’ method.  Then click ‘Open’.

If you open more than one image, they will all be ‘gathered’ on the main screen.  The first file
alphabetically will be displayed on top.

Switching Between Images

Click: File

The images currently loaded into JS9 will be listed at the top.  Select the
file you wish to view.
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Closing Image(s)

One image (the top image) can be closed OR all images can be closed
with just one click.

Click: File > close this image (or ‘close all images’)

Separating Images

If you opened more than one image, you will only be able to view one at a
time.  Separating the images opens each image into a different JS9 window,
stacked vertically in your browser.  Once you separate your images, scroll
down in your browser to view your other images.

Click: File > separate these images

Gathering Images

Gathering images takes all images opened in JS9 and puts them all into
one window.  You can only gather all images with this command.  To
gather only specific images, see below.

Gathering/Separating Specific/All
Images

Click:  View > Separate/Gather

The pop-up box will allow
the gathering and
separation of individual
images, selected groups
or all images.
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Contrast Adjustment
Adjusting contrast in JS9 is incredibly easy, but can be frustrating because it is so easy, a simple
accidental click will reset it!

Left click (and hold) anywhere on your image or even the gray screen on either side.  Move the pointer
left or right to change the contrast.  You will notice the scale on the bottom of the window changing to
indicate the level of contrast.  Release the button to set the contrast to that setting.

The contrast of only the active image in your window will change.  To change the
contrast of multiple images, you must change each image separately, OR you can do
the following:

1. Separate the images
2. Sync the images (see directions below)
3. Adjust to the desired contrast.  All images will be adjusted to the same level.

You can then gather the images, if desired, retaining their adjusted contrast.

If you make color or contrast adjustments which you are unable to undo,

Click: Color > reset color/bias

to bring the image back to its original state.

OR
Click:  View > Contrast Sliders

A window labeled “Scaling (JS9)” will appear.

Adjust the ‘Maximum’ slider to the left until the desired contrast
of your image is achieved.  The window can then be closed.
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Syncing Images

The sync image options allows two or more images to be modified in the same way at the same time.
Functions that can be used over multiple images include the ‘colormap’, ‘contrast’,  ‘zoom’ and ‘regions’
features.

To Sync Images, they first must be separated (see instructions above).

Click:  File > sync this image

Choose which image to sync with the current image or use the option at the bottom to choose ‘all
images’.

Once sync’d images are adjusted, they can be ‘unsync’d’ individually or as a complete group in the
same manner.
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Zoom
There are a few different ways to zoom an image in or out.  From the toolbar
menu, there is a ‘zoom +’ and ‘zoom -’ button.  The ‘zoom 1’ button takes the
zoom back to the original size.

The drop down ‘Zoom’ menu allows for immediate zooming to a specific level.

Moving around the image (Panner tool)
Zoomed in images will not be completely displayed in the JS9 window.  You can adjust what part of the
image is displayed in two different ways.

1) Right-click and hold on the image.  Move the image to the desired display and release.

2) Select the ‘panner’ button on the tool bar.
3) The ‘Panner’ window will open up.  The green box on the image represents the displayed

portion of the image on the JS9 window.  Left-click and hold on the green box, move it to display
the desired area of the image, then release.

4) The ‘Panner’ window can be closed or moved to a different part of the window using the title bar
on that window.
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Magnifier Tool

The magnifier tool enlarges the image in a separate window to allow for more precise positioning and
measuring.

● Click the ‘magnifier’ button on the toolbar to open the magnifier window.
● Move the magnifier window by dragging from its toolbar.
● The magnifier window will display the area around the mouse pointer as it moves over the

image.
● The magnifier window can be easily moved as needed to view your main image.
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Regions (part of the image to be measured, including pixel distance)

Regions is the term JS9 uses to signify a selected area of an image.  They are shown on the image in
green and have a variety of shapes.

Regions can be selected from the toolbar or from the region drop down menu.

Regions can be:
● removed through the menu or by clicking on them, then hitting ‘delete’ on your keyboard.
● Moved, rotated, resized

To analyze a region,

Click:  Analysis > Region Stats

A region can be manipulated to help determine the meaning of the measurements in the ‘Region Stats’
box.

For the ‘line’ region, the ‘box width’ is the number of pixels across the line.
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Pixel determination/location and intensity (green numbers in upper left
of an image)

The green numbers in the upper left of the JS9 screen indicate, in order:
● Light intensity
● X-value location of pixels
● Y-value location of pixels

Note the numbers listed on the images below related to the location of the mouse pointer on the image.

Light intensity = 250 X = 198.750 Y= 304.750

Light intensity = 8029 X = 255.250 Y = 235.750

Light intensity = 377 X = 272.750 Y = 222.750
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Region Analysis (Plot Profile, light intensity)

With a region selected,

Click:  Analysis > Plot Profile

The ‘Plot Profile’ box that pops up shows the intensity of the image across the region highlighted (in this
case, a line).

If you hover your mouse over the plot, crosshairs appear that give you the measurements of intensity
and position (x/y locations) in the upper left corner.  A green circle also appears on the region line
(green line) on the image and indicates the position of the pixels within the image being analyzed.

This tool can be used to help determine the edges of objects.  In this example, notice that the intensity
drops dramatically in the graph on the outside edges of the region (line) because the line’s ends are
placed beyond the bright part of the image.
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Blinking Function

The blinking function can be used to view multiple images in rapid succession.  Blinking images can be
cycled through manually or automatically.

This function can assist in looking for differences between images, such as the motion of an object
across the image field like an asteroid!

To use this function:
● Images should all be set to the same zoom and a

workable contrast
● Images should be ‘gathered’ in the same JS9

window

Click:  View > Blinking

In the ‘Image Blinking’ box
● Check the boxes for the images you want to blink.
● Images can be rearranged by left-click-hold and

dragging them up or down.
● Select ‘Blink Images’ to start the blinking of the

images
○ The displayed image will be boxed in green

in the ‘Image Blinking’ window.
● Click the ‘blink rate’ pull down menu to change the

blink rate.
● To manually go through the images, uncheck ‘Blink

Images’ and click ‘blink manually’ to cycle through
the selected images
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Blending Function

The blending function allows gathered (layered) images to be seen at the same time, with a
user-selected amount of opacity.  This function can be used to show the position of objects from
different images on the same composite image to aid in
measurements.

To use this function:
● Images should all be set to the same zoom and a

workable contrast
● Images should be ‘gathered’ in the same JS9

window

Click:  View > Blending

● Select which images you want to blend by checking
the boxes on the left

● Click on the ‘opacity’ dropdown menu and select the
amount of the intensity for that image you wish to see
in the blend.

● To blend the images, click the ‘Image Blending’ box.

The image shown here
is a blend of three
images which show the
different locations of the
moons of Jupiter.
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Add/Subtract Images (from each other) - Basic Image Processing

Adding or subtracting images from each other allows the user to notice the distinct differences between
two or more images.  It can also be used to layer (alternately add and subtract) multiple images to show
a sequence of motion between images.

Before you begin, images should be:
● Zoomed to the same level
● Contrast adjusted
● Gathered to a single JS9 window

Click:  View > Basic Image Processing

1. Select the files you wish to add/subtract using the dropdown menus.
2. Choose ‘Add’ or ‘Subtract’.
3. The modified image will be created in a new JS9 window with the filename ‘AnonymousXX’

where ‘XX’ is a number.
4. Those new files can then be added to or subtracted from by using the same procedure to create

a composite image of multiple files.

***I prefer the blend option to create composites.
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Apply Color (RGB), making a color composite

Color can be applied to images before blending to create a composite image based on red/green/blue
filtered grays images.  This creates a ‘colorized’ image.

Before you begin, images should be:
● Zoomed to the same level
● Contrast adjusted
● Separated to different JS9 windows
● Unsync’d

1. On the taskbar, open the dropdown menu ‘Color’, then select
the color you wish for that image.  Repeat this for your other
images using the different colors as needed.

2. Gather the images into on JS9 window.
3. Use the blending feature to blend your selected images,

adjusting the opacity to give your image the desired effect.
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Photometry

Photometry allows you to measure star brightness compared to the dark sky around it.  You can use the
3-circles annulus regions to calculate photometry. Pixels inside the smallest circle must be star pixels
and will define the star data. Pixels between the two largest circles will be sky pixel data.

Before you begin, images should be:
● Zoomed to the same level, whichever allows for adequate selection of the stars
● Contrast adjusted to be able to adequately select the region of the stars
● Separated to different JS9 windows
● Turn on Magnifier (to better locate star in region)

Click:  Analysis > Photometry

Move and resize the Plot Profile window to uncover the image.

1. Select “New Annulus
Region”.  A green triple-circle
will appear.  Move the center
of the circle over the star
being analyzed.  Use the
Magnifier to help center the
region on the star.
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2. Use the top slider to change the pixel
size of the inner circle.

Choose a size standard that allows the
circle to be near the size of the star.

The size of the star (and the number of
pixels needed) may differ based on the
amount of contrast.

Use this standard number of pixels for
every brightness reading.

Note:
● The size of the outer circle can be adjusted by dragging the blue squares on the outside

of the region.
● The space between the two outer rings of the region can be adjusted by moving the

lower slider to change the size of the middle circle.
● This adjustment, however, makes little change in the ‘sky median’ measurement if there

is dark sky around the star.

3. The number under ‘Star Brightness’ is the wanted data.
4. Repeat this sequence for other stars, such as a reference, in the same image:

New annulus region > move the region > change the number of pixels to your decided standard.

If you change the contrast or zoom on your image to better locate your region (green triple-circles), the
region data may disappear.  Select ‘Use annulus region’ then click on the region for the data to be
redisplayed.
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